On 23 Mar 2016, at 10:48, Denis Kudriashov <dionisiydk@gmail.com> wrote:
Hello.
I prepare new version of Mocketry with many new functions. And I have little question about some naming.
It will be possible to verify (at the end of test) that particular message was happened. My first suggestion was:
mock should receive someMessage
But from English it not sounds like it should be occurred in past. So what correct and not long sentence can be used here? maybe:
mock had received someMessage
mock should haveReceived someMessage
And same question for verification group of message sends (at the end of test):
[mock someMessage. mock2 someMessage2] should occur [mock someMessage. mock2 someMessage2] should occurInSameOrder
[ mock someMessage. mock2 somMessage2 ] should have beenSent
Does it sounds correct? What suggestions?
Best regards, Denis
Cheers, Max