Cédrick, I understand the diplomacy of the suggestion and I think it sounds like an interesting compromise. Before we jump at it, let me ask some questions: Does a class called BitNumber exists in the present (core) Pharo hierarchy? Does it makes sense to add a class like this? Which behaviour for BitNumber is not already subsumed by Number? my .0019999... -- Cesar Rabak Em 06/12/2009 11:36, Cédrick Béler < cdrick65@gmail.com > escreveu: 2009/12/5 <csrabak@bol.com.br> I understand the motivation and the implementation, but IMNHO the name of the method should be #asSmallInteger or if you want more general #asNumber. Why not #asBitNumber ? Returning 1 or 0 is not the same thing as returning a bit, except if we agree on creating a class called bit where the operations on it abide to what it is expected for a bit. my .019999... Cédrick