On Sat, 11 Dec 2010 19:34:12 +0100, Veronica Isabel Uquillas Gomez <vuquilla@vub.ac.be> wrote:
On 11 Dec 2010, at 10:33, Stéphane Ducasse wrote:
On Dec 11, 2010, at 6:47 AM, Francisco Ortiz Peñaloza wrote:
hi, i really like the idea, quite a challenge :)
But since you ask for our opinion I really dont like some of the methods' names specially the ones using "the" as prefix.
what is the alternative? class?
#itsClass #parentClass (suggested by Tudor)
Create a new poor mans's selector namespace and call it #ringClass (or #RINGclass or #ring_class or #RING_class to highlight the namespace part of the selector more). This way you retain the advantage of the familiarity of an old name (#class) and avoid clashes, for the price of a some extra keyboarding. Cheers, Peter
No it does not work (Point>>#x) class -> CompiledMethod and we want (Point>>#x) theClass -> Point
(Point>>#x) asMethodDefinition class -> MethodDefinition and we want (Point>>#x) asMethodDefinition theClass -> aClassDefinition for Point