Nov. 5, 2017
9:16 a.m.
On 5 Nov 2017, at 06:00, Stephane Ducasse <stepharo.self@gmail.com> wrote:
Hi guys
Why do we rename class Sort to introduce terms that have unknown, unclear, undocumented meaning?
+1
To me PluggableSortFunction is MUCH better than CollatorBlockFunction.
but pluggable is also bad, IMO. also I see there is some incoherence in the names: ChainedSortFunction -> this is kind of ok, but I think a âComposedSortFunctionâ is better. SortByPropertyFunction -> shouldnât be âPropertySortFunctionâ ? (coherent with the previous one) CollatorSortFunction -> this is like a âBlockSortFunctionâ or âValuableSortFunctionâ ? Esteban
Stef