Comment #18 on issue 3436 by cesar.rabak: #copyFrom: is broken http://code.google.com/p/pharo/issues/detail?id=3436 Your comments show consistency with your vision stated above about the need of an overhaul on the design of the interface (a.k.a. "API"), if you take the bulk of it. In order to sustain a civilized dialog, I need to concede you with this doubt. However, it seems to me this is flaring the judgment of proposal here: The method name has *copy* in it, hasn't? I _does_ return a *copy* of the object, doesn't? This issue #3436 is about: is it more adequate that a method called "copyFrom:" copies the state of an object or a part of one when it is a SequenceableCollection? Your other points have to be addressed elsewhere, be it in the mailing list as a preliminary discussion or as proposal here via a well formed issue. In order to avoid any doubts, my stance is that we adopt copyFrom: as an alias (or 'short cut') to "#copyFrom: start to: (self size)" in the most appropriate point of the Pharo object's hierarchy.