Jan. 27, 2017
6:02 p.m.
Hmm. Our language doesn't have method variables, either - class variables, instance variables, and temp variables (among others).
Maybe this should be called 'asTempConstant' ? (although a 'temporary constant' sound really, really weird...)
-cbc
Indeed , "temp variables" is what is named. I do not think we have to include "constant". There are other ways to express something that does not change. maybe "asReadOnlyTempVariable" or "asImmutableTempVariable" ?