Do whatever you want, I have no more motivation to discuss this anymore Ben On 24 Jan 2014, at 14:34, Pharo4Stef <pharo4Stef@free.fr> wrote:
Hi guys,
I think that we will rename all the asReactiveVariable that got introduced into their old name asValueHolder. And we will rename the class too to its old name.
Why?
I think that we should not change at the last moment ValueHolder into ReactiveVariable even if the name could be better:
- First there are books around (and not only mine) that use this vocabulary for decades. - Second all the Spec tools developed by people right now do not work in latest 3.0. - I think that this change does not worth the noise it introduced: all the future changes of Spec-based tools that will be using asReactive will not work in Pharo3.0.
We are in beta and now we should not change that. Then I would appreciate that we discuss it before. Because I would not change that even between versions of Pharo.
Stef