2016-03-23 11:02 GMT+01:00 Max Leske <maxleske@gmail.com>:
But from English it not sounds like it should be occurred in past. So what correct and not long sentence can be used here? maybe:
mock had received someMessage
mock should haveReceived someMessage
Thank's for suggestions. Thats idea from Marcus too. But it feels too long. But maybe. Now I actually already rename #receive to #haveReceived. But I hope for better sentence.
And same question for verification group of message sends (at the end of test):
[mock someMessage. mock2 someMessage2] should occur
[mock someMessage. mock2 someMessage2] should occurInSameOrder
[ mock someMessage. mock2 somMessage2 ] should have beenSent
It's long too. And I wish reduce number of separated words because it is not good practically. It raises more questions: how it is implemented, what the better name for intermediate object (result of have in that case) and others. At least your suggestion will be like [ mock someMessage. mock2 somMessage2 ] should haveBeenSent Another idea is to use #happen word: [ mock someMessage. mock2 somMessage2 ] should happen