On 11 Apr 2012, at 18:39, Norbert Hartl wrote:
this is pretty cool. A good feature to have less to think. In a normal environment there will be a front-end server that serves request to the external interface. So the zinc server is well put on the loopback interface. I just would opt to use another name than interface. There are basically two things when it comes to network interfaces: an interface and a ip address. They belong to the same thing but they don't belong to each other. So to me it is really confusing to name it "interface" while meaning the address. So I think #bindTo: or #bindingAddress: would be better options.
Yeah, maybe that would be a good idea, Norbert. I took the name from Socket>>listenOn:backlogSize:interface: without really thinking about it. I like #bindingAddress: the most. I'll sleep over it and then decide whether to change it or not, but I probably will. Thx, Sven