Ok, I commited a slice with a different selector name we discussed with Ben a while ago. #bindKeyCombination:toAction: On Mon, Aug 5, 2013 at 9:42 AM, Igor Stasenko <siguctua@gmail.com> wrote:
On 4 August 2013 15:50, Esteban Lorenzano <estebanlm@gmail.com> wrote:
I would use #onKeyCombination:do: to keep coherency with the framework.
why not naming it onKeyCombinationInKeyBindingsFramework:do: :)
Really?
OnKey: is good because it short.
Short is not always better, come on igor!
And not ambiguous (you can use single key(s)
yes but also... *as well as key combinations*, And then why Key is ok? The role the object is playing there is the one of a key combination. If a key can be used as a key combination it is only circumstantial.
but that details).
You know better than a lot of people that details matter :). And now you can solve the detail instantaneously by just making the selector more intention revealing. I do not see the problem.
On Aug 4, 2013, at 3:04 PM, Stéphane Ducasse <stephane.ducasse@inria.fr> wrote:
Hi ben and others
we are introducing onKey:do: for bindings so that we can control the complexity and the registration of announcements. So if you can I have a look it would be good.
https://pharo.fogbugz.com/default.asp?11299
Stef
-- Best regards, Igor Stasenko.