Am 22.02.2014 um 18:49 schrieb Tudor Girba <tudor@tudorgirba.com>:
Excellent, Stef!
I reviewed a bit the code: - The name log denotes the recording of multiple events. However, the Log class models only one event, not many. Thus, a more suitable name would be LogEvent. Or maybe LogEntry (like in StarTrek :))
I had the same objections. But I can also see the huge win of the short name because it is used all the time. Norbert
- Similarly, System Logger>>logs should be something like logEvents/logEvents.
I like it a log that LogEvents are full objects because we can subclass them with specific semantics. This is particularly important if we want to build tools for custom applications. The first application I have in mind is Zinc.
Zinc already comes with a logging mechanism that treats LogEvents as objects, but they are all of the same type, so in the end, if you want to track the events for request/response you have to reverse engineer the text. These semantics could be preserved.
From what I see, the main difference between the Zinc log system and the SystemLogger is that the latter has a dispatcher that can dispatch to multiple loggers. Is there anything else that is different? I think it would be cool to merge the two.
Doru
2014-02-22 13:24 GMT+01:00 Pharo4Stef <pharo4Stef@free.fr>:
-- www.tudorgirba.com
"Every thing has its own flow"