On 10 May 2011 12:35, Mariano Martinez Peck <marianopeck@gmail.com> wrote:
If I understand correctly, before the trailers we used to use just an array of bytes...now we use a CompiledMethodTrailer. So, the method copyWithTrailerBytes:Â is misleading.
yes. it should be named copyWithTrailer: instead, but since at the time i introducing trailers there was only bytes, i had to preserve the name for compatibility (among other things). Btw, if you look at CompiledMethod, there's a lot of things which can be cleaned-up/refactored. For example all code which managing sourcePointer(s) and SourceFiles, not belongs to CompiledMethod. It should reside somewhere in SourceFileArray (or its subclass).
cheers
-- Mariano http://marianopeck.wordpress.com
-- Best regards, Igor Stasenko AKA sig.