And done. Version 3.4 deprecates "should got" and introduces "should receive". All docs are updated. Prebuilt PDF can found here https://ci.inria.fr/pharo-contribution/view/Books/job/PharoBookWorkInProgres... 2016-05-18 11:59 GMT+02:00 Denis Kudriashov <dionisiydk@gmail.com>:
So at the end of week I will rename "should got" into "should receive"
2016-04-27 23:39 GMT+02:00 Carlos Lombardi <carlombardi@gmail.com>:
Hi again,
ok, just to have coherence between the names for the two possible outcomes of a method, you could use #beReturnedBy instead of #beReturnedFrom: . You would have #beReturnedBy: and #beRaisedBy:
On Wed, Apr 27, 2016 at 10:00 AM, Denis Kudriashov <dionisiydk@gmail.com> wrote:
2016-04-27 0:33 GMT+02:00 Carlos Lombardi <carlombardi@gmail.com>:
... maybe
#result should beTheResultOf: [mock someMessage]. #result should not beTheResultOf: [mock anotherMessage].
It's nice.I think "The" can be omitted:
#result should beResultOf: [mock someMessage].
But anyway I use word #return because there are different types of result: value return and error signal. There is no expression for last case but it would be like:
anError should beRaisedBy: [mock someMessage]