On 29 Nov 2016, at 09:58, Aliaksei Syrel <alex.syrel@gmail.com> wrote:
"DataSource" is responsible for providing visual elements that represent items in a data set.
I don't see how word "Store" fits here, because DataSource does not store anything. DataSource is also not the best name since it is not a data source itself. An object that is now called DataSource, basically just knows a single function that from mathematical point of view can be defined as follows: f: Object -> Morph . You see, it is a mapping, not a souse or store.
Store != Storage. A store is a place where you go to get stuff (same as FileSystem stores: they give you access to different filesystems, as a FTDataSource gives you access to different data structures) :) In Gtk3, you have GtkListView, and GtkListStore, for example. And DataSource is another stuff in Cocoa, from where I borrowed the design: https://developer.apple.com/reference/appkit/nstableviewdatasource <https://developer.apple.com/reference/appkit/nstableviewdatasource> So⦠I still rest my argument. Anyway⦠we will NEVER reach a 100% agreement. We just need to go with what fits better current design/general idea. Esteban
Cheers, Alex
On 29 November 2016 at 09:44, Denis Kudriashov <dionisiydk@gmail.com <mailto:dionisiydk@gmail.com>> wrote:
2016-11-29 9:35 GMT+01:00 Esteban Lorenzano <estebanlm@gmail.com <mailto:estebanlm@gmail.com>>:
yes, something like TableCellSource or TableCellProvider is more intention revealing.
No, because is not *just* a cell provider. TableDataSource, TableStore, TableProvider, yes.
I kind of like âTableStoreâ.
And if we have TableMorph then this guy should be TableMorphStore IMO.