Feb. 26, 2016
7:51 p.m.
I like the idea that you package to postcondition, invariant and precondition not in the methods themselves but in separate methods. I did not think about that but this is nice because you do not pollute the code and we could put them in a precondition protocols. About the pragma why not isEmpty <preconditionOf: #add:> I think that it is nicer than <contract: #postcondition ....> Now can you support the old value? Stef