2010/3/17 Stéphane Ducasse <stephane.ducasse@inria.fr>:
:) I was concerned about 'win32' versus 'Win 32' versus 'Win32' I'm having fun (really) rewriting by hand all the SmalltalkImage current and I reading the code and fixing it. This is cool I'm learning a lot of simple stuff.
Stef
That's why I tend to avoid automated scripts. You always want to rewrite more than you thought ! At least, I try to review changed methods, there's always something to learn. Nicolas
Issue 2159: We should clean all the platformName = 'Win32' and: [osVersion = 'CE']
This is not good to have all these strings to encode platform support. We should move some code to SmalltalkImage
SmalltalkImage>>win32 Â Â Â Â ^ 'Win 32'
SmalltalkImage>>isWin32CE Â Â Â Â ^ (self platformName = 'Win32' and: [self osVersion = 'CE'])
...
Concerning readability, both are readable. Concerning discovering capability (what are all specific Win32CE features in the image ?), the message is easier to track than the String. Concerning maintenance (hability to change implementation details/features), the message is clearly superior.
For example, I can imagine you buy a device that isWin32CECompatible. OK, bad example it's more past than future ;)
Nicolas
Stef _______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project