Sept. 23, 2012
3:15 p.m.
instVarNamed: is implemented on Object this is why it looks into the object class. but reimplementing on Class would make sense.
I don't see any problem here, besides the maybe confusing names... #instVarNamed: works on class-side as well, used to read the values in the living instance. What would your #instVarNamed: do?