April 21, 2015
8:44 a.m.
On 21 Apr 2015, at 10:36, Christophe Demarey <Christophe.Demarey@inria.fr> wrote:
To come back to my proposition, it is just a first step to BDD to not prevent people to define tests with something like shouldAccountBalanceBePositiveAfterEachOperation (more behavior driven) rather than testMyWonderfulMethod that may leads people to test the implementation details and not the expected behavior.
Not that your naming ideas are bad, but right now you can write testAccountShouldBePositiveAfterEachOperation which is not that bad