Aug. 23, 2011
4:56 p.m.
I would love to change that because this is terribly confusing for me that the accept: and visit: methods are not well named. stef On Aug 23, 2011, at 2:33 PM, Camillo Bruni wrote:
Hi everyone,
I just had a quick look at the RBNodes. Is there a particular reason why the visitor pattern methods are prefixed on both sides with 'accept'?
eg.
RBArrayNode >> acceptVisitor: aProgramNodeVisitor ^ aProgramNodeVisitor acceptArrayNode: self
camillo