March 31, 2017
5:24 p.m.
I read and could not understand. Now what I see is that there are view in the class name. So at least dataSource should be called dataSourceViewProvider. On Fri, Mar 31, 2017 at 9:56 AM, Stephan Eggermont <stephan@stack.nl> wrote:
On 31/03/17 08:14, Stephane Ducasse wrote:
To me a datasource should deliver data and not UI elements.
AFAIK it is an old established designation for this. It is the data source of the table view, not of the persistency layer. It provides a single point of access to the data in a form that the table view can understand, which is cells.
https://developer.apple.com/reference/uikit/uitableviewdatasource https://developer.apple.com/reference/uikit/uitableviewdelegate
Stephan