Hi. On Wed, Jun 25, 2014 at 8:06 AM, Norbert Hartl <norbert@hartl.name> wrote:
Am 25.06.2014 um 16:55 schrieb Esteban A. Maringolo <emaringolo@gmail.com
:
2014-06-25 11:52 GMT-03:00 Esteban Lorenzano <estebanlm@gmail.com>:
On 25 Jun 2014, at 11:49, Marcus Denker <marcus.denker@inria.fr> wrote:
On 25 Jun 2014, at 16:43, Esteban A. Maringolo <emaringolo@gmail.com> wrote:
Slot \SimpleSlot (current iv slot)
Yes, the naming of that one⦠I think we just need to take the freedom of iterating. For now I called it âInstanceVariableSlotâ, but that might be confusing and it is a long word.
but is less confusing than âSimpleSlotâ, which basically says nothing, IMO
What about SimpleInstanceVariableSlot? (just kidding)
I don't like over descriptive class names. Because they restrict you from using it for other, unexpected, purposes or contexts.
The question to me is why this is "over descriptive". We have a tradition here to be descriptive and intention revealing. It happens everywhere except when it comes to instance variables it is instVarAt: instVarNamed: etc. I never liked them. Another question might be the usage context. Why is it called InstanceVariableSlot anyway? Is there a difference if the slot is attached to the instance side or class side? Isn't it really just a VariableSlot? The context for the instance is where it is used. Asking an object for instance variables and class instance variables could just return a collection of VariableSlots, no?
Instances have instanceVariables, and classes have instanceVariables. There are also ClassVariables, which are a completely different thing (and commonly referred to directly from instance, class, and subclasses directly). It would be good not to make this any more complex (confusing?) than those concepts already are. -cbc
Norbert