Hi martin I agree should: is not that communicating. I would favor [] assert [] assertWithDescription: 'funky preconditions' Stef On Oct 15, 2009, at 8:35 PM, Martin McClure wrote:
Henrik Johansen wrote:
Why not rename Object>>assert: to should:, so it avoids breaking polymorphism, and keep TestCase>>assert: reserved for a boolean argument to stay compatible with SUnit in other dialects?
On the negative side, it might not be as intuitive using should: for pre/post-assertions, as well as inconvenient to remember the difference between assert: and should: in TestCases. Not big enough negatives to outweigh the benefits though, imo.
Henry,
Sorry, I hadn't read this mail before making a proposal.
I agree that renaming Object>>assert: to #should: would be an improvement. But I still think it's probably better to remove it altogether and send #assert to a block. It may just be me, but I've always felt that as a selector 'should' doesn't really communicate the intent as well as 'assert'.
Regards,
-Martin
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project