On Mon, Sep 24, 2012 at 8:28 PM, Camillo Bruni <camillobruni@gmail.com>wrote:
On 2012-09-24, at 20:24, Guillermo Polito <guillermopolito@gmail.com> wrote:
What if we do it the other way? Add #variableNames to the instances :)
in my opinion wrong :/, then you can start to replicate the whole class-side interface on the instance side... that's a never-ending circle.
I'm not strongly against nor in favor for any of those approaches.
besides, that's yet another method on Object? :D
The problem is not the amount of methods per se but the packaging of most of them -which btw is much better than some years ago-, and the tools showing lots of info in such annoying way.
Nautilus new variableNames = Nautilus instVarNames.
And them
Nautilus new variableNames ==> #('announcer' 'browsedEnvironment' 'browsingHistory' 'plugins' 'selectedCategory' 'selectedClass' 'selectedGroup' 'selectedMethod' 'selectedPackage' 'showCategories' 'showComment' 'showGroups' 'showHierarchy' 'showInstance' 'showPackages' 'ui' 'uiClass')
Nautilus new instVarNamed: 'announcer'
?
Of course, that will happen/work at metaclass level too.
Maybe rename #instVarNames to #myInstancesVariableNames?
Guille