Am 23.05.2013 um 07:43 schrieb stephane ducasse <stephane.ducasse@free.fr>:
I disagree and this is not coherent with the ensureFile and ensureDirectory
What does it mean anyway? File and Directory are things, delete is an action/verb and deleted is a state. To me the only one that makes sense is that you can ensure a state. To me ensureFile sounds odd, too. It should be called ensureFileExists. Norbert
On May 22, 2013, at 10:33 PM, Sean P. DeNigris <sean@clipperadams.com> wrote:
Camillo Bruni-3 wrote
because it is the final state, the file is deleted. it emerged out of a longer discussion with sean, mariano and me I think
Yes, we discussed thoroughly in the ml [1] (you were a part, but it was a while back). The objection, which I came to agree with, was that you're not "ensuring delete" because it may not be deleted (e.g. if it never existed).
[1] http://forum.world.st/FileReference-should-throw-error-when-deleting-unexist...
----- Cheers, Sean -- View this message in context: http://forum.world.st/Pharo-dev-could-we-rename-ensureDeleted-into-ensureDel... Sent from the Pharo Smalltalk mailing list archive at Nabble.com.