in general, rule of thumb when extending classes should be âuse the most specific name possibleâ, for instance: #magritteDescription instead of #description, etc. but everybody makes mistakes⦠in voyage I added methods #save, #remove instead a #voyageSave, #voyageRemove⦠one could argue that since that is *not* part of the image is ok, but no: is a framework so possibility of collisions are always there (of course, when doing your own project methods is another things⦠and Iâm sure I can find other exceptions⦠but as I said ⦠âin generalâ) Esteban
On 11 Jan 2017, at 11:46, Henrik Nergaard <draagren@outlook.com> wrote:
And Object/Association >> #tail
Best regards, Henrik
-----Opprinnelig melding----- Fra: Pharo-dev [mailto:pharo-dev-bounces@lists.pharo.org] PÃ¥ vegne av Esteban Lorenzano Sendt: 11 January 2017 10:13 Til: Pharo Development List <pharo-dev@lists.pharo.org> Emne: Re: [Pharo-dev] Strange DNU effect on Windows with Pastell
On 11 Jan 2017, at 10:12, Esteban Lorenzano <estebanlm@gmail.com> wrote:
at least we should rename it as âtreeMorphHeadâ⦠just âheadâ is too generic.
âtreeNodeHeadâ I meant.
Esteban
On 11 Jan 2017, at 10:03, Sven Van Caekenberghe <sven@stfx.eu> wrote:
On 11 Jan 2017, at 09:55, Torsten Bergmann <astares@gmx.de> wrote:
But why the hell would there be a Object>>#head ?!
IMHO such general selectors at this level should not be used unless there is a very good reason to do so.
Yes - some Morphic addition. Version says: BenjaminVanRyseghem in 2013 Only used in MorphTreeNodeMorph and to me this smells. We should nuke it.
Thx T.
Looking in a 6 image, there is also an even uglier implementation in
Association>>#head
^ (key isKindOf: Association) ifTrue: [ key head ] ifFalse: [ key ]
Duh.
And I can't seen any senders...