Oct. 6, 2008
7:53 a.m.
which could make sense. Now I saw some other places where this is way to avoid to be precise.
Even if slightly longer, I find the following expression more readable a isNil or: [ a isEmpty ] than a isEmptyOrNil Especially with the long form I know at one glance what it *exactly* does. I don't think it is an advantage to introduce hundreds of control structures with unclear semantics. These things make porting code very hard too. Cheers, Lukas -- Lukas Renggli http://www.lukas-renggli.ch