Aug. 17, 2017
7:52 p.m.
Hi guys my son coded in Pharo 60 testGuessUrlPart |dg8| dg8 := GameItem new; name: 'Dragon Quest VIII : Journey Of The Cursed King'; console: 'PS2'. self assert: dg8 guessUrlPart equals: 'dragonquestviiijourneyofthecursedking' and guess what he broke the system. We should not accept such kind of behavior. name: should not change the name of the class. I do not know the solution but I fear when I will teach 160 students this fall. We should make sure that Pharo is not a system only for experts! any idea is welcome https://pharo.fogbugz.com/f/cases/20322/name-sent-to-a-class-SHOULD-NOT-auto... Stef