Thanks Ben. This is cool. I proposed to David to do a pair screen session but my agenda will return soon to chaos :). Stef
On 20 Feb 2019, at 16:58, Ben Coman <btc@openinworld.com> wrote:
Hi David,
I invite you to consider this an opportunity to submit a PR to fix it. I'm happy to walk you though the process if you ping me on Discord chat. I remember it felt cool to have my first code integrated. Pharo is yours.
cheers -ben
On Wed, 20 Feb 2019 at 02:16, ducasse <stepharo@netcourrier.com <mailto:stepharo@netcourrier.com>> wrote: Hello David
Indeed this is a good catch. Can you open a bug entry on github? Else I will do it but this is cool to get involved that way
On 19 Feb 2019, at 17:37, David Richards <david.i.richards.iii@gmail.com <mailto:david.i.richards.iii@gmail.com>> wrote:
Why does the class name KmGlobalDispatcher have a small 'm'?
Should it be more consistently named KMGlobalDispatcher, as all other classes in package: 'Keymapping-Core'?
Object subclass: #KmGlobalDispatcher instanceVariableNames: 'dispatcher' classVariableNames: '' package: 'Keymapping-Core'
Just curious why this name seems inconsistent. I don't recall seeing an inconsistency with class name prefixes in any other package group. Is this just a mistake, or rather an opportunity to learn something interesting about how classes should be named in Pharo? As a beginner, I'm not sure which.
Thanks David