Session is a class, not an instance that is a BIG difference. The same goes for VirtualMachine, OSPlatform, OSEnvironment etc. These are all classes, but you only work with their instances: OSPlatform current == Smalltalk os VirtualMachine current == Smalltalk vm OSEnvironment current == Smalltalk os environment and thus, it is quite natural to deduce Session current == Smalltalk session it's all symmetric, not strange objects that have names like classes but are actually instances. On 2013-09-12, at 20:51, Igor Stasenko <siguctua@gmail.com> wrote:
Even more, it feels like we introducing another global (so users can write 'Session current' , but why not just 'Session' then?) and so a step backwards as to me. Because we trying to get rid of all those Display, World, InputSensor , ActiveHande etc globals for years.
And last thing: there should be only one way to get current session object. now there's two: Smalltalk session and Session current
and so, users now will inevitably raise the question: what is the right 'true' API for accessing it? and inevitably we will have two fighting camps, if we leave this thing in image and be used in various projects.
On 13 September 2013 01:33, Igor Stasenko <siguctua@gmail.com> wrote:
+1 too. Session is a bad name for a class. More than that, the people who introduced it, didn't care about: - removing unused session ivar from SmalltalkImage class - that putting #reset in Session class side, means exposing resetting mechanism to public, instead of keeping it private (and it is quite important to keep it private, because session should be reset once and only once and only in single , fully controllable place)
from that perspective, i'd prefer using 'session' ivar in SmalltalkImage instead of 'current' in Session.
On 12 September 2013 15:13, Esteban A. Maringolo <emaringolo@gmail.com>wrote:
+1
Very abstract names are fine when you have namespaces, otherwise I rather chose more specific names.
Regards!
Esteban A. Maringolo
2013/9/12 Torsten Bergmann <astares@gmx.de>
In Pharo 3.0 there is a new class "Session" - to represent the current smalltalk session. Using the term "Session" is very abstract.
IMHO I would rather like to see it named more specific like "ImageSession", "PharoSession" or "SmalltalkSession" before it get used too much.
Any comments? T.
-- Best regards, Igor Stasenko.
-- Best regards, Igor Stasenko.