I had imagined the update number of Pharo and PharoCore would be the same? do you need to know any more about the core image? ...we could embed the core's SystemVersion in the Pharo image. version iVar will be deprecated when I get around to it. did you mean putting behaviour on the instance side? I would not, but do something like "during Pharo build...." SystemVersion core: SystemVersion current copy. "Make image Pharo" SystemVersion current type: 'Pharo'; suffix: 'rc1' "etc" and then in the about dialog you can access SystemVersion core & SystemVersion current. This is at the expense of a new class variable. however, i'm not sure if it's really needed. Could the release notes tell you where the image comes from? cheers, Mike
Ok...the problem is that I have just checked and this changes are only in 1.1 isn't it ?
:(Â Â Â So...what we do ? we keep like this until 1.1 ?
oh sorry yes they are only in 1.1. Â You just need to change version: string using some string manipulation. Â If you keep it in the same format it will parse correctly by code that expects the 1.1 format. On principle I did not backport the SystemVersion changes behaviour to 1.0 since it was already at the end of the cycle. However i just migrated the data to work across core branches.
and you can change the suffix as well, but personally i would not use the date in the image name.
For the date you refer to year, month and number of version inside the month ?
yes I think it is too complicated a version scheme. The dev tag is also synonymous with Pharo.
so if your Pharo image is currently Pharo1.0-10505-rc1dev10.01.1 I would call it Pharo-1.0-10505-rc1. This is the same scheme that the core image uses, and Pharo 1.1 will have this behaviour already using #imageVersionString since it is in 1.1.
That's cool. I evaluate:
SystemVersion current version: 'Pharo-1.0-10505-rc1'
And seems to be almost what I want. It would be cool (maybe not for 1.0, but for 1.1) if we can see not only the version of Pharo, but also opf the pharoCore...So, SystemVersion could understand:
coreVersion: Â and version:
Then in System -> About, if I am in a core image I would see:
 PharoCore1.0rc1 Latest update: #10505
And if I am in Pharo I would see
Pharo1.0-10505-rc1dev10.01.1 PharoCore1.0rc1 Latest update: #10505
Right now, with what you told me is enought for 1.0, but maybe for 1.1 would be cool to have that.
what do you think ?
cheers
mariano
thanks, Mike
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project