Lukas Renggli <renggli@...> writes:
In that case, we could have isAbstractClass or something else. I feel this information is important.
What would be your isAbstract be useful for?
- SUnit will still have to implement its own #isAbstract to decide if a class should be runnable or just provide test templates. - Pier will still have to implement its own #isAbstract to decide if a class should show up in the GUI. - Magritte will still have to implement its own #isAbstract to decide if an arbitrary class can be instantiated from the GUI. - ...
Looks to me like these are application specific definitions of abstractness. Why not name them #isAbstractTest, #isAbstractComponent et cetera? While in the same time, there is a system-wide notion of abstract classes for which the generic #isAbstract should be reserver. NB, I am making this injection in the hope to disentangle to issue of method naming from the issue of the exact implementation of a general #isAbstract method (on which I agree with Lukas that it should be chosen carefully). cheers, AA