On Mon, 22 Sep 2008 20:03:31 +0300 "Igor Stasenko" <siguctua@gmail.com> wrote:
and i doubt that such 'not-so-three' lines are more readable than line , presented by me :)
true. my oversight.
I suspecting that this code was ported to smalltalk from C, and 'caseOf:' used simply because it is easier to port things blindly, in same manner as it was written in original, than doing hard work rewriting code to accommodate in new language/environment.
Or the original implementor was under the impression/constraint that only "primitive" data types could be transmitted.
Of course, i can't blame people doing this. Sometimes we need results fast. And when things done & working, we need something else to do (fast as well) :)
hmm... I wonder about the long-term effects of this approach though. This instant-gratification-code is what a friend of mine usually left around for me to take care of and clean up and it tends to mutate into dangerous beasts when left unattended for a while. just making smalltalk, s.