2011/8/8 Nicolas Cellier <nicolas.cellier.aka.nice@gmail.com>:
I also noted this: (Array does notUnderstand: #nextPut:) and it comes from:
MouseOverHandler>>handleAsMouseEnter: anEvent     | asMouseEnterEvent |     asMouseEnterEvent := anEvent asMouseEnter.     enteredMorphs := enteredMorphs contents.     enteredMorphs reverseDo: [ :anEnteredMorph |         self inform: asMouseEnterEvent to: anEnteredMorph originatedFrom: anEvent ifNotFocusedDo: [] ]
enteredMorphs is changing indead from WriteStream -> Array. IMHO mutating an inst var is very bad behaved This should be corrected ASAP
This class is really confusing.. According to its use (see senders to #mouseOverHandler) it actually handling more than just mouse over events. I would say it should be named MouseEventHander :) But still , its hard to say, why it is so complex.. and what its purpose. -- Best regards, Igor Stasenko AKA sig.