Comment #5 on issue 3436 by rydier: #copyFrom: is broken http://code.google.com/p/pharo/issues/detail?id=3436 If we end up deprecating and reimplementing, at least make the "new" implementation in SequenceableCollection, where it can be found in STX and GnuST. I still don't think it's a good idea to add to the SequenceableCollection API though, because: - It's not ANSI (VW for instance does not have it) - There is already copyFrom:to: and allButFirst: filling the same role nearly as easy - It'll break code for no better reason than to increase readability (unless you actually look up its implementation, in which case it's quite clear what it does) - There's yet another point of difference if you want to have your code running on both Squeak and Pharo