Hi, Nice work! Just the English does not sound quite well for statements like: mock should got someMessage mock should not got anotherMessage. I know that there was a long discussion about naming these. I do not remember the outcome, but still I think other alternatives would be better: mock should haveReceived someMessage. mock should not haveReceived anotherMessage. or even mock shouldnt haveReceived anotherMessage. Also, for this statement: mock stub someMessage willReturn: 1000. I think I would favor: mock stub someMessage toReturn: 1000. or mock stub someMessage returns: 1000. What do you think? Cheers, Doru
On Apr 6, 2016, at 5:29 AM, Denis Kudriashov <dionisiydk@gmail.com> wrote:
I am glad to present simplest mocks for Pharo. In this version Mocketry is dramatically improved and changed. I try to provide most simple way to stub any message to any object and to verify any occurred behaviour.
You can read full details in my blog http://dionisiydk.blogspot.fr/2016/04/new-version-of-mocketry-30.html
Here is short example:
mock := Mock new. mock stub someMessage willReturn: 1000.
mock someMessage should be: 1000. mock should got someMessage. mock should not got anotherMessage.
rect := 0@0 corner: 2@3. rect stub width willReturn: 1000.
rect area should be: 3000 "area = width * height". rect should got width.
-- www.tudorgirba.com www.feenk.com "Every thing has its own flow."