Jan. 7, 2018
9:49 a.m.
Hi Eliot, I'm just preparing a fogbugz issue and PR to add PrimitiveOSError to Pharo and was wondering about the class name. As you say in the class comments, errorName is typically set to #'operating system error' (I haven't seen anything else), which makes the class name and errorName somewhat redundant. What do you think of renaming the class to PrimitiveError, which will make it a bit more general and extensible in future? Thanks, Alistair