Aug. 28, 2011
6:27 p.m.
On Aug 28, 2011, at 8:10 PM, Lukas Renggli wrote:
We have a class Halt and the class-side is empty. This seems to be the right place to hold all the code in the protocols #debugging and #debuggin-haltonce of Object. With a few renames we could get a really nice DSL:
Halt now. Halt if: a = 2. Halt once.
Nice! I want that. This would even allow for making the #haltIf: less overloaded and provide a explicit control flow based halt with something like this: Halt selector: #DoIt. or maybe better: Halt ifCalledFrom: #testMyWonderfulBuggyTest Marcus -- Marcus Denker -- http://marcusdenker.de