June 5, 2010
1:33 p.m.
Seriously, I think the method should be called "h". Just that. Nobody's going to type a method name as long as haltIfShiftPressed for debugging. Debugging is not about readability. Cheers, Niko On Sat, Jun 5, 2010 at 3:31 PM, Niko Schwarz <niko.schwarz@googlemail.com> wrote:
Hi list,
http://code.google.com/p/pharo/issues/detail?id=2510&can=4&colspec=ID%20Type...
I suggest the following snippet in object to ease debugging:
Object>>haltIfShiftPressed  self haltIf: [Sensor shiftPressed]
Pharo image: core Pharo core version: #11383 Virtual machine used: Â pharo-vm-osx
-- http://scg.unibe.ch/staff/Schwarz twitter.com/nes1983 Tel: +41 076 235 8683
-- http://scg.unibe.ch/staff/Schwarz twitter.com/nes1983 Tel: +41 076 235 8683