I usually say âblockâ but I have nothing against a name change. I think âclosureâ would be an intention revealing name, I like it. And Iâm willing to say âclosureâ from now on :) On 17.04.2014, at 15:35, Alexandre Bergel <alexandre.bergel@me.com> wrote:
Well⦠the whole community of programming language call a closure a closure. Calling a block what is actually a closure may not be a well-marketed move in my opinion.
Alexandre -- _,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;: Alexandre Bergel http://www.bergel.eu ^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;.
On Apr 17, 2014, at 10:29 AM, Sebastian Sastre <sebastian@flowingconcept.com> wrote:
On Apr 17, 2014, at 10:08 AM, Yuriy Tymchuk <yuriy.tymchuk@me.com> wrote:
I would rather rename is to Block, as everyone is calling it a âblockâ.
That might be actually a good idea
sebastian
o/
PS: thinking in that line there is also âContextâ as, conceptually, what these blocks of code want to do is to keep the evaluation in a specific context. But to ease know-how transference and type less Iâd rather go with the most popular name, as you suggested: âBlock'