2015-07-27 4:24 GMT-03:00 Nicolai Hess <nicolaihess@web.de>:
2015-07-27 8:26 GMT+02:00 Hernán Morales Durand <hernan.morales@gmail.com> :
2015-07-26 15:49 GMT-03:00 Esteban Lorenzano <estebanlm@gmail.com>:
Hi,
Well, If there wouldn't be already a way to do it, I wouldn't care which one to take. But this is not the case: we are discussing the introduction of a new vocabulary when there is already another who is fulfilling the place. In that sense, the proposed method solves a problem who is actually not there. If we do not like #<<, then we should remove it from system, but please, let's not add a more limited method when we have a more generic one who does the job...
<< is horrible, it reminds me to std::cout in C++ and all those cryptic languages where you cannot write a line without checking the API reference manual.
I like "<<" because it reminds me to std::cout in C++
:)
Maybe you're more comfortable in a C++ forum too ;) Seriously, I don't know, but whatever you choose please make it human inferrable from just by reading the selector name. Because << is arithmetic/bitwise operator for most coders in the world, and there are more developers to come and be newbies, than smalltalkers ever. Hernán