On 2012-09-24, at 20:24, Guillermo Polito <guillermopolito@gmail.com> wrote:
What if we do it the other way? Add #variableNames to the instances :)
in my opinion wrong :/, then you can start to replicate the whole class-side interface on the instance side... that's a never-ending circle. besides, that's yet another method on Object? :D
Nautilus new variableNames = Nautilus instVarNames.
And them
Nautilus new variableNames ==> #('announcer' 'browsedEnvironment' 'browsingHistory' 'plugins' 'selectedCategory' 'selectedClass' 'selectedGroup' 'selectedMethod' 'selectedPackage' 'showCategories' 'showComment' 'showGroups' 'showHierarchy' 'showInstance' 'showPackages' 'ui' 'uiClass')
Nautilus new instVarNamed: 'announcer'
?
Of course, that will happen/work at metaclass level too.
Maybe rename #instVarNames to #myInstancesVariableNames?
Guille