Branch: refs/heads/4.0 Home: https://github.com/pharo-project/pharo-core Commit: 15b6092ae6f264589225b0455dcc17d228552b1e https://github.com/pharo-project/pharo-core/commit/15b6092ae6f264589225b0455... Author: Jenkins Build Server <board@pharo-project.org> Date: 2014-10-08 (Wed, 08 Oct 2014) Changed paths: M Graphics-Tests.package/RectangleTest.class/instance/tests-rectangle functions/testPointNearestTo.st R OpalCompiler-Core.package/OCSemanticWarning.class/instance/correcting/interactive.st M OpalCompiler-Core.package/OCShadowVariableWarning.class/instance/correcting/variable_shadows_.st M OpalCompiler-Core.package/OpalCompiler.class/instance/accessing/requestor_.st M Refactoring-Core.package/RBChangeMethodNameRefactoring.class/instance/preconditions/myConditions.st M Refactoring-Core.package/RBRenameInstanceVariableRefactoring.class/README.md M Refactoring-Core.package/RBRenameInstanceVariableRefactoring.class/definition.st A Refactoring-Core.package/RBRenameInstanceVariableRefactoring.class/instance/refactoring/browsedEnvironment.st A Refactoring-Core.package/RBRenameInstanceVariableRefactoring.class/instance/refactoring/executeRefactoring_.st A Refactoring-Core.package/RBRenameInstanceVariableRefactoring.class/instance/transforming/addNewAccessors.st A Refactoring-Core.package/RBRenameInstanceVariableRefactoring.class/instance/transforming/removeOldAccessors.st A Refactoring-Core.package/RBRenameInstanceVariableRefactoring.class/instance/transforming/renameAccessorsReferences.st M Refactoring-Core.package/RBRenameInstanceVariableRefactoring.class/instance/transforming/transform.st A Refactoring-Core.package/RBRenameInstanceVariableRefactoringTest.class/README.md A Refactoring-Core.package/RBRenameInstanceVariableRefactoringTest.class/definition.st A ScriptLoader40.package/ScriptLoader.class/instance/pharo - scripts/script291.st A ScriptLoader40.package/ScriptLoader.class/instance/pharo - updates/update40291.st M ScriptLoader40.package/ScriptLoader.class/instance/public/commentForCurrentUpdate.st Log Message: ----------- 40291 14189 OCSemanticWarning does not need #interactive https://pharo.fogbugz.com/f/cases/14189 13588 Rename inst var should rename accessors too https://pharo.fogbugz.com/f/cases/13588 14166 RectangleTest#testPointNearestTo failing since 40283 https://pharo.fogbugz.com/f/cases/14166 http://files.pharo.org/image/40/40291.zip