El mar, 23-03-2010 a las 15:04 +0100, Mariano Martinez Peck escribió:
2010/3/23 Miguel Enrique Cobá Martinez <miguel.coba@gmail.com> El mar, 23-03-2010 a las 13:56 +0100, Mariano Martinez Peck escribió: > > > On Tue, Mar 23, 2010 at 1:52 PM, Stéphane Ducasse > <stephane.ducasse@inria.fr> wrote: > mariano > > cleanUp: true > support agrresive cleanup = "shrink" > > > > > Thanks...I didn't know. So...instead of cleanUp: aBoolean why not > to have a method called shrink ? or something better that someone can > think :)
Because not only shrinks the image, but also does other clean up tasks like resetting caches and similar. They have a shrink effect, but mainly are for cleaning things for example for release.
You didn't understand me. When not to call it agressiveClean instead of having a fac.. boolean and having to do aBoolean ifTrue: [ blah blag] ifFalse: [ blah blah blah]
There is something I don't see ? I would have:
cleanUp
agressiveCleanUp
where this last one, may call cleanUp too
Oh, I see. No idea, that is how Keith (I think) and Andreas proposed the change for Squeak that Stef applied to Pharo. :) Cheers
> > Cheers > > Mariano > > > On Mar 23, 2010, at 10:24 AM, Mariano Martinez Peck wrote: > > > > > > > On Tue, Mar 23, 2010 at 10:19 AM, Lukas Renggli > <renggli@gmail.com> wrote: > > What I do on my build server is to unload the tests: > > > > (MCWorkingCopy allManagers > > inject: Gofer new > > into: [ :gofer :each | > > ((each packageName endsWith: 'Test') or: > [ each > > packageName endsWith: 'Tests' ]) > > ifTrue: [ gofer package: each > packageName ]. > > gofer ]) > > unload. > > > > > > ScriptLoader >> cleanUpForProduction do that but similary: > > > > #(#Tests #CollectionsTests #CompilerTests #FreeTypeTests > #GraphicsTests #KernelTests #MorphicTests #MultilingualTests > #NetworkTests #ToolsTest) > > do: [ :each | (MCPackage named: each) unload ]. > "unload SUnit" > > Smalltalk globals > > at: #TestCase > > ifPresent: [ :class | SystemChangeNotifier > uniqueInstance noMoreNotificationsFor: class ]. > > #(#SUnitGUI #SUnit) do: [ :each | (MCPackage named: > each) unload ]. > > > > > > Maybe we you should change it ? > > > > > > > Hi folks. I was playing a bit trying to shrink a little a > PharoCore image. > > > My idea was to think a shrink that was be acceptable for > the most common > > > scenario: a runtime (production) environment where. Of > course, some of the > > > things I do in the shrinks has side effects, but most of > the times, you can > > > deal with that in such scenarios. > > > > Shouldn't most of the code you publish be part of the > <cleanup> protocol? > > > > > > You refere to the "new" cleanUp protocol ? > > > > The thing is that not everything is a cleanUp, but a shrink. > Suppose the code that zap all the organizations...that's not a > cleanUp. > > So, maybe yes, but not all of them. > > > > Cheers > > > > Mariano > > > > > > Lukas > > > > -- > > Lukas Renggli > > http://www.lukas-renggli.ch > > > > _______________________________________________ > > Pharo-project mailing list > > Pharo-project@lists.gforge.inria.fr > > > http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project > > > > _______________________________________________ > > Pharo-project mailing list > > Pharo-project@lists.gforge.inria.fr > > > http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project > > > _______________________________________________ > Pharo-project mailing list > Pharo-project@lists.gforge.inria.fr > http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project > > > _______________________________________________ > Pharo-project mailing list > Pharo-project@lists.gforge.inria.fr > http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
-- Miguel Cobá http://miguel.leugim.com.mx
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
-- Miguel Cobá http://miguel.leugim.com.mx