On 22 May 2016, at 17:51, stepharo <stepharo@free.fr> wrote:
loadConfigurationButton: aList <menu> aList act: [ :presenter | self onLoadFrom: presenter ] icon: Smalltalk ui icons configIcon entitled: 'Load configuration (do not install project)'
why we could not have something like
loadConfigurationButton: aList <menu> aList act: [ :presenter | self onLoadFrom: presenter ] icon: #configIcon entitled: 'Load configuration (do not install project)â
in this case it should be called #act:iconNamed:entitled:, IMO. but I was thinking and what I actually would do is to model the class Icon, and then you can add an extension to symbol â#asIconâ who call some "Icon fromSymbol: blah" then the strategy of resolution can change without changing anything in the system :P (I know you would not like #asIcon, but I think in this case it would be better than all those "Smalltalk ui icons iconNamed: blah" all around the image)
and the class knows how to fetch it?