Sean P. DeNigris wrote
I did a first pass
I made some of the more obvious fixes/enhancements... Issue 15414: TxText Cleanup for Pharo 5.0 #1 Fixes in Tx repo: TxText-Styler-SeanDeNigris.4 - Update for TxCursorAttribute to TxMouseCursorAttribute rename TxText-Model-SeanDeNigris.52 Higher-level: - Rename TxCursorAttribute to TxMouseCursorAttribute; we must differentiate between the insertion cursor, which is already named the "Cursor" Cleanups: - Rename TxModel>>#setNewContents, which does not follow Constructor Parameter Method, to #initializeContents - Many comment enhancements - Several small refactorings - Extract TxInterval>>#normalize to return a copy with start < end; this logic was duplicated everywhere TxText-Athens-SeanDeNigris.45 Higher-level: - Initial TxBlockCursor implementation as an experiment, mostly copied from TxCaretCursor. It might be to have a pluggable drawing strategy instead of a whole separate class... Cleanups: - Many comment enhancements - Several small refactorings ----- Cheers, Sean -- View this message in context: http://forum.world.st/Tx-Pass-tp4822173p4822193.html Sent from the Pharo Smalltalk Developers mailing list archive at Nabble.com.