Now it is clear and makes sense. Yes, it should be renamed! On Mar 6, 2016 11:10 AM, "stepharo" <stepharo@free.fr> wrote:
Wait you confuse me.
My only point is
- Class should not end in ing but in er DeepCopier is not DeepCopying PragmaCollector is not PragmaCollecting
- So if I set (using a setter) an attribute to an object passing a resizer the name of the setter should not be resizing: (BlLayoutExactResizer new)
I could understand if this is a general method but the selector is not really nice either I would prefer in that case resizeWith: (BlLayoutExactResizer new)
Am'I clear? Stef
Le 6/3/16 10:54, Aliaksei Syrel a écrit :
In case of layout strategy it is actually questionable. Because it is LayoutStrategy WHO resizes. all current *Resizing objects define HOW strategy resizes element. From this perspective resizer is layout strategy.
We request native English speakers :) On Mar 6, 2016 10:38 AM, "stepharo" <stepharo@free.fr> wrote:
Hi alex
I would like rewrite
exact: aNumber self resizing: (BlLayoutExactResizer new size: aNumber)
as
exact: aNumber self resizer: (BlLayoutExactResizer new size: aNumber)
you have
Object subclass: #BlLayoutAxisParams instanceVariableNames: 'resizing' classVariableNames: '' package: 'Bloc-Core-LayoutStrategy-Core'
and the resizing method is in private protocol however it looks like it is used a lot outside.
So
should I change all the senders + protocol?
Stef