Sept. 16, 2015
2:20 p.m.
In Random>>nextValue I notice the comment: "This method does NOT update the seed; repeated sends answer the same value." Thus the following produces all the same values... oc := OrderedCollection new. r := Random new. 5 timesRepeat: [ oc add: r nextValue ] . oc inspect. Am I being too pedantic thinking this ancient method should be named #currentValue. Are there historical constraints to be wary of? Its only significant in-Image sender is Random>>next which would then be... ^ (seed := self currentValue) / m cheers -ben