Hi, I would agree with that. The only thing to take into account is that this can introduce incompatibilities with external libraries, but I do not think this would be much. Cheers, Doru
On May 14, 2016, at 3:03 PM, stepharo <stepharo@free.fr> wrote:
I would rename
Pragma>>keyword into Pragma>>selector
Pragma>>selector into Pragma>>methodSelector so like that it is coherent with
Message and method api and with Pragma>>methodClass Le 13/5/16 à 14:33, stepharo a écrit :
Color >> gtInspectorColorIn: composite <gtInspectorPresentationOrder: 30>
composite morph title: 'Color'; display: [ BorderedMorph new color: self ]
pragma := (Color >> #gtInspectorColorIn:) pragmas first pragma arguments
30 pragma keyword #gtInspectorPresentationOrder:
I wonder why pragma returns their selector using keyword and not selector?
Especially since message API uses selector.
Pragma >> message "Answer the message of the receiving pragma."
^ Message selector: self keyword arguments: self arguments.
Stef
-- www.tudorgirba.com www.feenk.com "What we can governs what we wish."