On 10.08.2010, at 10:45, Stéphane Ducasse wrote:
Just an api point
why preservesC... and not preserverC
I'm always confuse with the infinitive and third person singular situation.
You mean preserveC...? The preserve(r)C.. was a typo, right? I think preservesC... qualifies for a testing selector. But as I wrote in my description of the problem I would call it coalesceCDATASections: aBoolean or enableCoalescing disableCoalescing The functionality that is described here is better known as coalescing. And it describes better what is going. If a parser is coalescing two things will happen. CDATA sections will be read in as text nodes and then subsequent text nodes are coalesing into a single text node. my 2 cents, Norbert
Stef
Here is an example that demonstrates parsing with CDATA section preservation: doc := (XMLDOMParser on: '') preservesCDataSections: true; parseDocument. doc root firstNode When evaluated with cmd-p, it produces:
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project