On Tue, Dec 13, 2011 at 2:04 PM, Nicolas Cellier < nicolas.cellier.aka.nice@gmail.com> wrote:
2011/12/13 Stéphane Ducasse <stephane.ducasse@inria.fr>:
I just came back to eater after 7 hours of train
Ah yes, you probably wrote original code after 15h of airplane and 8h time difference ;)
I wonder if SharedPool were inherited in original st-80 ?
Yes. But IIRC SharedPools were *not* inherited in pre-Namespace VisualWorks, and they don't exist in Namespaced VW. Here's the class variable lookup method in Smalltalk-80 V2: Behavior>scopeHas: varName ifTrue: assocBlock "Look up varName in this class, its superclasses, and Smalltalk. If it is there, pass the association to assocBlock, and answer true; else answer false." | assoc | self withAllSuperclasses do: [:sup | (sup poolHas: varName ifTrue: assocBlock) ifTrue: [^true]]. assoc _ Smalltalk associationAt: varName ifAbsent: []. assoc == nil ifFalse: [assocBlock value: assoc. ^true]. ^false
Nicolas
On Dec 13, 2011, at 10:33 PM, Sean P. DeNigris wrote:
Stéphane Ducasse wrote
What do you think? may be we should rename it hasLocalPoolvarNamed:
That sounds clearer. #has vs. #uses is more subtle and potentially confusing.
-- View this message in context:
http://forum.world.st/hasPoolVarNamed-semantics-tp4191675p4192155.html
Sent from the Pharo Smalltalk mailing list archive at Nabble.com.
-- best, Eliot